Saber si tu tema es compatible con Gutenberg

Saber si tu tema es compatible con Gutenberg

¿Qué es eso de Gutenberg y en qué afecta a mi web hecha en WordPress?, ¿cómo saber si lo tienes instalado y si tu tema es compatible con Gutenberg?.

Si alguna de estas preguntas te ronda por la cabeza y te surgen dudas, en este post voy a intentar aclarártelas para que puedas dormir más tranquilo o tranquila esta noche 😛

¿Qué es Gutenberg?

Hace ya algunos días se ha liberado la nueva versión 5.0 de WordPress, la cual, además de otras novedades como por ejemplo el nuevo tema Twenty Nineteen, incorpora el temido editor Gutenberg.

Gutenberg es el nuevo editor de WordPress, es lo que se denomina un editor de bloques (algo parecido a un constructor visual tipo Divi, Visual Composer, Elementor…). Pero no creas que teniendo Gutenberg instalado, si utilizas un constructor visual, este dejará de funcionar o se quedará obsoleto, ¡al contrario!, podrás seguir utilizándolo con total seguridad. Desde que se ha conocido la noticia de que Gutenberg iba a sustituir al Editor de WordPress clásico, todas las empresas tanto de plugins como de temas han hecho sus deberes y han preparado sus productos para la llegada de Gutenberg.

Gutenberg, ¿una decisión empresarial?

Se dice que Gutenberg nació como una pura necesidad de mercado, ya que otros servicios gratuitos de diseño y alojamiento web como Wix o Blogger, hacían una competencia directa a wordpress.com. Estos servicios tienen un editor muy intuitivo para construir webs, y ¿sabes en qué consiste esta forma de construir los diseños?… ¡efectivamente!, en la utilización de bloques.

Teniendo en cuenta que si bien wordpress.com (y otros servicios parecidos) es gratuito, también existe una versión de pago que te permite alojar tu web en los servidores propios de la empresa en cuestión, y en el caso de WordPress, también puedes instalar algunos temas y plugins que con la versión gratuita no podías utilizar.

Auttomatic desoye a los usuarios y también la máxima que dice: si algo funciona bien no lo toques.

WordPress ha impuesto obligatoriamente el nuevo editor Gutenberg a partir de la versión 5.0

El aviso de cambio en el editor no gustó a la Comunidad WordPress, eso de imponer un editor a todos los usuarios (hay que tener en cuenta que el 30% de todas las páginas web a nivel mundial están hechas con WordPress), no gustó nada, hasta tal punto que ha surgido un movimiento que opta por continuar con el Editor clásico, aunque en este caso no estará disponible directamente como un editor tal cual, se instalará como un plugin más.

Si tienes algo de experiencia con WordPress (y sino también), te aconsejo que hagas una instalación en local de WordPress y que pruebes el nuevo editor Gutenberg hasta que te hagas con él. No solo porque es el nuevo editor personalizado para crear contenido, sino, como te he dicho antes, Gutenberg ha llegado para quedarse, hasta tal punto que se ha publicado la fecha oficial de caducidad del Editor Clásico: el 31 de diciembre de 2021.

¿En qué afecta Gutenberg a mi web?

Auttomatic lleva mucho tiempo avisando de que Gutenberg va a llegar para quedarse, por lo que las empresas y los desarrolladores tanto de temas como de plugins, han tenido suficiente tiempo para adaptar sus productos al nuevo editor visual.

Es más que probable que tu tema ya esté preparado para utilizar el nuevo editor, pero si no sabes si tu tema es compatible con Gutenberg, no lo actualices a lo loco. Antes de hacerlo, visita la web del desarrollador de tu tema y busca la información al respecto. Si no encuentras nada, antes de actualizar tu versión de WordPress a la versión 5.0, escribe un email a la empresa solicitando información al respecto y los pasos que debes seguir para poder actualizar tu versión del tema de forma segura.

Te recomiendo encarecidamente que antes de actualizar a WordPress 5.0, hagas una copia de seguridad de tu web. En este artículo te enseño cómo puedes hacerlo.

Como te he comentado anteriormente, es más que probable que el desarrollador de tu tema haya trabajado en la compatibilidad del mismo con Gutenberg. Así que, si instalas la última versión de WordPress, el único inconveniente que debería producirse en tu web,es tener en cuenta que todo cambia a la hora de crear páginas y post.

Nueva forma de crear contenido

Ya no usarás el método natural de crear la entrada o página y escribir directamente, ahora deberás crear bloques uno a continuación de otro, también podremos eliminarlos, duplicarlos y crear bloques compartidos para poder reutilizarlos más adelante. ¡Una maravilla!.

Si has utilizado (o utilizas) un Editor como Visual Composer, Elementor o Divi, seguro que no tendrás problemas en hacerte rápidamente con esta forma de crear contenidos.

Si eres nuevo en esto de WordPress y has creado tu página web a partir del 6 de diciembre de este año, lo más seguro es que ya tengas instalado Gutenberg, por lo que la curva de aprendizaje del mismo será como la de cualquier otro tema o plugin (ya que no has conocido ninguna otra forma anterior para crear contenido).

Por el contrario, si has creado tu web hace ya tiempo, la curva de aprendizaje de Gutenberg quizás sea un poquito más pronunciada, sobre todo si no tienes experiencia previa utilizando constructores visuales para crear tus contenidos.

Sea cual sea tu situación, debes invertir tiempo en aprender y dominar este nuevo editor, ya que Gutenberg no es el futuro de WordPress, es el presente.

Mi tema no es compatible con Gutenberg, ¿qué debo hacer?

Es obvio que los bloques de Gutenberg deben tener sus propios estilos para hacerlos compatibles con el tema que tenga activo la instalación de WordPress, pero también se puede dar la circunstancia de que el propio tema activo superponga sus propios estilos por encima de estilos externos (de otros plugins e incluso del propio Gutenberg).

También se puede dar la situación inversa, que Gutenberg solicite al tema activo el uso expreso de sus propios estilos, sobrescribiendo los que tiene programados el propio tema.

Si tu tema no es compatible con Gutenberg y quieres hacerlo compatible, te aconsejo que veas este artículo que Fernando Tellado ha  publicado en ayudawp.com, en el que te explica paso a paso lo que debes hacer para que tu tema sea compatible con el nuevo editor.

Si esto es demasiado complicado para ti, afortunadamente (y como te he dicho antes), puedes utilizar el plugin llamado Classic Editor, el cual restaurará todas las funcionalidades de contenidos que tenía el antiguo editor. Esta es la mejor forma de que tengas un poquito más de tiempo hasta que te hagas a las nuevas funcionalidades de Gutenberg y actualices definitivamente tu editor de contenidos.

Y si mi tema es Divi, ¿cómo lo hago compatible con Gutenberg?

Afortunadamente, la gente de Elegant Themes ha hecho su trabajo. ¡Pero ojo, esto es muy muy importante!, para poder hacer totalmente compatible tu instalación de Divi con Gutenberg, debes tener al menos la versión 3.18 de Divi. ¡Repito!, asegúrate de que tu versión de Divi es al menos la versión 3.18.

Dicho esto, vamos a ver cómo podemos hacer compatibles Divi y Gutenberg.

Si ya tienes la última versión de Divi, cuando vayas a crear una entrada o una página, te aparecerá un popup que te permitirá elegir entre el Editor por defecto o el Editor Divi Builder. Como es lógico harás clic en Usar Divi Builder para acceder a todas las opciones de este tema.

Usar Gutenberg con Divi

Según Elegant Themes, la mejor forma de disfrutar la experiencia del constructor Divi en WordPress 5.0 es activar estas dos opciones que te muestro a continuación:

  • En el Escritorio de WordPress vas al menú Divi, y haces clic en la entrada Opciones del tema.
  • Haces clic en la ficha Builder y a continuación haces clic en la sub ficha Advanced. Ahora solo tienes que activar las opciones que se llaman Enable Classic Editor y Enable The Latest Divi Builder Experience y por último pulsar el botón Guardar cambios.

Disfrutar la experiencia Divi con Gutenberg

Si no te sientes cómodo con Gutenberg, siempre podrás volver a utilizar el editor clásico. La forma de hacerlo es muy sencilla:

  • En el Escritorio de WordPress vete de nuevo al menú Divi, y haces clic en la opción Opciones del tema.
  • A continuación haces clic en la ficha Builder y a por último haces clic en la sub ficha Advanced. Ahora solo tienes que activar la opción que se llama Enable Classic Editor y desactivar la opción Enable The Latest Divi Builder Experience y por último pulsamos el botón Guardar cambios.

Desctivar Gutenberg en Divi


¿Qué te ha parecido el artículo?. Házmelo saber en los comentarios que tienes más abajo. Estoy deseando leerte.

Por último, si crees que este artículo puede ser interesante para algún amigo tuyo, te agradecería enormemente que lo compartieras con él y con todo el mundo a través de las Redes Sociales.

Puntúa este artículo:
[Total: 0 - Promedio: 0]

Puede que también te interese...

Deja un comentario

Información básica sobre protección de datos
Responsable: Jose González Bueno.
Finalidad: Moderación y publicación de comentarios.
Destinatarios: No se comunican datos a terceros.
Derechos: Tienes derecho a acceder, rectificar, exportar y suprimir tus datos.

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

He leído y acepto la política de privacidad de este sitio. *